Out-of-bounds Read Affecting python2-rpm package, versions <4.14.1-22.4.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.64% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-PYTHON2RPM-2661727
  • published14 Apr 2022
  • disclosed15 Oct 2021

Introduced: 15 Oct 2021

CVE-2021-20266  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 python2-rpm to version 4.14.1-22.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2-rpm package and not the python2-rpm package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

A flaw was found in RPM's hdrblobInit() in lib/header.c. This flaw allows an attacker who can modify the rpmdb to cause an out-of-bounds read. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1