Buffer Overflow Affecting python3-louis package, versions <3.11.0-150200.3.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.36% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-PYTHON3LOUIS-5414907
  • published6 Apr 2023
  • disclosed5 Apr 2023

Introduced: 5 Apr 2023

CVE-2023-26767  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 python3-louis to version 3.11.0-150200.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-louis package and not the python3-louis package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Buffer Overflow vulnerability found in Liblouis v.3.24.0 allows a remote attacker to cause a denial of service via the lou_logFile function at logginc.c endpoint.

CVSS Base Scores

version 3.1