Incorrect Authorization Affecting python3-paramiko package, versions <2.4.3-150100.6.15.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.41% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-PYTHON3PARAMIKO-3063451
  • published26 Oct 2022
  • disclosed25 Oct 2022

Introduced: 25 Oct 2022

CVE-2018-1000805  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 python3-paramiko to version 2.4.3-150100.6.15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-paramiko package and not the python3-paramiko package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect Access Control vulnerability in SSH server that can result in RCE. This attack appear to be exploitable via network connectivity.

CVSS Base Scores

version 3.1