Deserialization of Untrusted Data Affecting ruby2.5-rubygem-actionpack-5_1 package, versions <5.1.4-3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.89% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-RUBY25RUBYGEMACTIONPACK51-2702942
  • published14 Apr 2022
  • disclosed22 Sept 2020

Introduced: 22 Sep 2020

CVE-2020-8164  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 ruby2.5-rubygem-actionpack-5_1 to version 5.1.4-3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-actionpack-5_1 package and not the ruby2.5-rubygem-actionpack-5_1 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.

CVSS Base Scores

version 3.1