Out-of-bounds Write Affecting shim package, versions <15.8-150100.3.38.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
5.42% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-SHIM-6729389
  • published30 Apr 2024
  • disclosed29 Apr 2024

Introduced: 29 Apr 2024

CVE-2023-40547  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 shim to version 15.8-150100.3.38.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shim package and not the shim package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

A remote code execution vulnerability was found in Shim. The Shim boot support trusts attacker-controlled values when parsing an HTTP response. This flaw allows an attacker to craft a specific malicious HTTP request, leading to a completely controlled out-of-bounds write primitive and complete system compromise. This flaw is only exploitable during the early boot phase, an attacker needs to perform a Man-in-the-Middle or compromise the boot server to be able to exploit this vulnerability successfully.

CVSS Base Scores

version 3.1