Out-of-bounds Read Affecting shim package, versions <15.8-150100.3.38.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.41% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-SHIM-6729400
  • published30 Apr 2024
  • disclosed29 Apr 2024

Introduced: 29 Apr 2024

CVE-2023-40549  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 shim to version 15.8-150100.3.38.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shim package and not the shim package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

An out-of-bounds read flaw was found in Shim due to the lack of proper boundary verification during the load of a PE binary. This flaw allows an attacker to load a crafted PE binary, triggering the issue and crashing Shim, resulting in a denial of service.

CVSS Base Scores

version 3.1