Buffer Overflow Affecting slurm-webdoc package, versions <20.02.6-3.3.4


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.24% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-SLURMWEBDOC-2695403
  • published14 Apr 2022
  • disclosed24 Nov 2020

Introduced: 24 Nov 2020

CVE-2020-27745  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 slurm-webdoc to version 20.02.6-3.3.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-webdoc package and not the slurm-webdoc package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Slurm before 19.05.8 and 20.x before 20.02.6 has an RPC Buffer Overflow in the PMIx MPI plugin.

CVSS Base Scores

version 3.1