Out-of-bounds Read Affecting tar package, versions <1.30-3.6.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.1% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-TAR-2683382
  • published14 Apr 2022
  • disclosed29 Mar 2021

Introduced: 29 Mar 2021

CVE-2021-20193  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 tar to version 1.30-3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tar package and not the tar package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

A flaw was found in the src/list.c of tar 1.33 and earlier. This flaw allows an attacker who can submit a crafted input file to tar to cause uncontrolled consumption of memory. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1