Out-of-bounds Read Affecting bluez-cups package, versions <5.55-3.6.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-BLUEZCUPS-2669628
  • published14 Apr 2022
  • disclosed22 Jul 2021

Introduced: 22 Jul 2021

CVE-2021-3588  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 bluez-cups to version 5.55-3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bluez-cups package and not the bluez-cups package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

The cli_feat_read_cb() function in src/gatt-database.c does not perform bounds checks on the 'offset' variable before using it as an index into an array for reading.

CVSS Base Scores

version 3.1