Improper Authentication Affecting booth package, versions <1.0-150300.18.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.31% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-BOOTH-2964995
  • published2 Aug 2022
  • disclosed1 Aug 2022

Introduced: 1 Aug 2022

CVE-2022-2553  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 booth to version 1.0-150300.18.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream booth package and not the booth package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

The authfile directive in the booth config file is ignored, preventing use of authentication in communications from node to node. As a result, nodes that do not have the correct authentication key are not prevented from communicating with other nodes in the cluster.

CVSS Base Scores

version 3.1