Improper Input Validation Affecting elfutils-lang package, versions <0.177-150300.11.3.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.7% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-ELFUTILSLANG-2965157
  • published2 Aug 2022
  • disclosed1 Aug 2022

Introduced: 1 Aug 2022

CVE-2017-7613  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 elfutils-lang to version 0.177-150300.11.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream elfutils-lang package and not the elfutils-lang package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

elflint.c in elfutils 0.168 does not validate the number of sections and the number of segments, which allows remote attackers to cause a denial of service (memory consumption) via a crafted ELF file.