Improper Input Validation Affecting freeradius-server-perl package, versions <3.0.21-150200.3.12.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.14% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-FREERADIUSSERVERPERL-3184323
  • published28 Dec 2022
  • disclosed27 Dec 2022

Introduced: 27 Dec 2022

CVE-2022-41861  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 freeradius-server-perl to version 3.0.21-150200.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeradius-server-perl package and not the freeradius-server-perl package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A flaw was found in freeradius. A malicious RADIUS client or home server can send a malformed abinary attribute which can cause the server to crash.

CVSS Base Scores

version 3.1