Improper Certificate Validation Affecting gfbgraph-devel package, versions <0.2.3-150000.3.5.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.71% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-GFBGRAPHDEVEL-2989746
  • published24 Aug 2022
  • disclosed23 Aug 2022

Introduced: 23 Aug 2022

CVE-2021-39358  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 gfbgraph-devel to version 0.2.3-150000.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gfbgraph-devel package and not the gfbgraph-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

In GNOME libgfbgraph through 0.2.4, gfbgraph-photo.c does not enable TLS certificate verification on the SoupSessionSync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.

CVSS Base Scores

version 3.1