Off-by-one Error Affecting glibc-devel package, versions <2.31-150300.9.12.1


0.0
high
0
10

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.04% (6th percentile)
Expand this section
NVD
7.8 high
Expand this section
SUSE
7.4 high
Expand this section
Red Hat
7.4 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-GLIBCDEVEL-2643663
  • published 14 Apr 2022
  • disclosed 4 Feb 2022

How to fix?

Upgrade SLES:15.3 glibc-devel to version 2.31-150300.9.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glibc-devel package and not the glibc-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A flaw was found in glibc. An off-by-one buffer overflow and underflow in getcwd() may lead to memory corruption when the size of the buffer is exactly 1. A local attacker who can control the input buffer and size passed to getcwd() in a setuid program could use this flaw to potentially execute arbitrary code and escalate their privileges on the system.