Buffer Overflow Affecting glibc-devel package, versions <2.31-150300.9.12.1


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.91% (83rd percentile)
Expand this section
NVD
9.8 critical
Expand this section
SUSE
5.3 medium
Expand this section
Red Hat
7 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-GLIBCDEVEL-2643780
  • published 14 Apr 2022
  • disclosed 4 Feb 2022

How to fix?

Upgrade SLES:15.3 glibc-devel to version 2.31-150300.9.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glibc-devel package and not the glibc-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

The deprecated compatibility function clnt_create in the sunrpc module of the GNU C Library (aka glibc) through 2.34 copies its hostname argument on the stack without validating its length, which may result in a buffer overflow, potentially resulting in a denial of service or (if an application is not built with a stack protector enabled) arbitrary code execution.