Integer Overflow or Wraparound Affecting glibc-devel package, versions <2.31-9.3.2



    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    EPSS 1.14% (85th percentile)
Expand this section
9.1 critical
Expand this section
5.1 medium
Expand this section
Red Hat
9.1 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-GLIBCDEVEL-2662346
  • published 14 Apr 2022
  • disclosed 8 Dec 2021

How to fix?

Upgrade SLES:15.3 glibc-devel to version 2.31-9.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glibc-devel package and not the glibc-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

The wordexp function in the GNU C Library (aka glibc) through 2.33 may crash or read arbitrary memory in parse_param (in posix/wordexp.c) when called with an untrusted, crafted pattern, potentially resulting in a denial of service or disclosure of information. This occurs because atoi was used but strtoul should have been used to ensure correct calculations.