Buffer Overflow Affecting glibc-devel package, versions <2.31-150300.46.1


low

Snyk CVSS

    Attack Complexity High

    Threat Intelligence

    EPSS 0.12% (47th percentile)
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
4.6 medium
Expand this section
SUSE
0 info

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-GLIBCDEVEL-5353836
  • published 1 Apr 2023
  • disclosed 31 Mar 2023

How to fix?

Upgrade SLES:15.3 glibc-devel to version 2.31-150300.46.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glibc-devel package and not the glibc-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A vulnerability was found in GNU C Library 2.38. It has been declared as critical. This vulnerability affects the function __monstartup of the file gmon.c of the component Call Graph Monitor. The manipulation leads to buffer overflow. It is recommended to apply a patch to fix this issue. VDB-220246 is the identifier assigned to this vulnerability. NOTE: The real existence of this vulnerability is still doubted at the moment. The inputs that induce this vulnerability are basically addresses of the running application that is built with gmon enabled. It's basically trusted input or input that needs an actual security flaw to be compromised or controlled.