Use After Free Affecting glibc-devel package, versions <2.31-150300.63.1


0.0
medium
0
10

Snyk CVSS

    Attack Complexity High
    Availability High

    Threat Intelligence

    EPSS 0.1% (42nd percentile)
Expand this section
NVD
5.9 medium
Expand this section
SUSE
5.9 medium
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-GLIBCDEVEL-6009083
  • published 19 Oct 2023
  • disclosed 18 Oct 2023

How to fix?

Upgrade SLES:15.3 glibc-devel to version 2.31-150300.63.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glibc-devel package and not the glibc-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A flaw was found in glibc. In an uncommon situation, the gaih_inet function may use memory that has been freed, resulting in an application crash. This issue is only exploitable when the getaddrinfo function is called and the hosts database in /etc/nsswitch.conf is configured with SUCCESS=continue or SUCCESS=merge.