Improper Certificate Validation Affecting glib-networking-lang package, versions <2.62.4-3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.02% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-GLIBNETWORKINGLANG-2652293
  • published14 Apr 2022
  • disclosed6 Dec 2021

Introduced: 6 Dec 2021

CVE-2020-13645  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 glib-networking-lang to version 2.62.4-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glib-networking-lang package and not the glib-networking-lang package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

In GNOME glib-networking through 2.64.2, the implementation of GTlsClientConnection skips hostname verification of the server's TLS certificate if the application fails to specify the expected server identity. This is in contrast to its intended documented behavior, to fail the certificate verification. Applications that fail to provide the server identity, including Balsa before 2.5.11 and 2.6.x before 2.6.1, accept a TLS certificate if the certificate is valid for any host.

CVSS Base Scores

version 3.1