Improper Validation of Array Index Affecting kubernetes1.18-client package, versions <1.18.20-150200.5.25.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.43% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-KUBERNETES118CLIENT-12200035
  • published26 Aug 2025
  • disclosed25 Aug 2025

Introduced: 25 Aug 2025

CVE-2021-3121  (opens in a new tab)
CWE-129  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 kubernetes1.18-client to version 1.18.20-150200.5.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kubernetes1.18-client package and not the kubernetes1.18-client package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

An issue was discovered in GoGo Protobuf before 1.3.2. plugin/unmarshal/unmarshal.go lacks certain index validation, aka the "skippy peanut butter" issue.

CVSS Base Scores

version 3.1