Improper Input Validation Affecting libasm-devel package, versions <0.177-150300.11.3.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.64% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBASMDEVEL-2965068
  • published2 Aug 2022
  • disclosed1 Aug 2022

Introduced: 1 Aug 2022

CVE-2017-7609  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libasm-devel to version 0.177-150300.11.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libasm-devel package and not the libasm-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

elf_compress.c in elfutils 0.168 does not validate the zlib compression factor, which allows remote attackers to cause a denial of service (memory consumption) via a crafted ELF file.