Integer Overflow or Wraparound Affecting libgmp10-32bit package, versions <6.1.2-4.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.46% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBGMP1032BIT-2652255
  • published14 Apr 2022
  • disclosed6 Dec 2021

Introduced: 6 Dec 2021

CVE-2021-43618  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libgmp10-32bit to version 6.1.2-4.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgmp10-32bit package and not the libgmp10-32bit package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

GNU Multiple Precision Arithmetic Library (GMP) through 6.2.1 has an mpz/inp_raw.c integer overflow and resultant buffer overflow via crafted input, leading to a segmentation fault on 32-bit platforms.

CVSS Base Scores

version 3.1