Out-of-bounds Read Affecting libgstsdp-1_0-0 package, versions <1.16.3-150200.4.6.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
5.37% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBGSTSDP100-3110504
  • published9 Nov 2022
  • disclosed8 Nov 2022

Introduced: 8 Nov 2022

CVE-2021-3522  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libgstsdp-1_0-0 to version 1.16.3-150200.4.6.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgstsdp-1_0-0 package and not the libgstsdp-1_0-0 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

GStreamer before 1.18.4 may perform an out-of-bounds read when handling certain ID3v2 tags.

CVSS Base Scores

version 3.1