Integer Overflow or Wraparound Affecting libksba-devel package, versions <1.3.5-150000.4.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.67% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBKSBADEVEL-3322454
  • published16 Feb 2023
  • disclosed15 Feb 2023

Introduced: 15 Feb 2023

CVE-2022-47629  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libksba-devel to version 1.3.5-150000.4.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libksba-devel package and not the libksba-devel package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

Libksba before 1.6.3 is prone to an integer overflow vulnerability in the CRL signature parser.

CVSS Base Scores

version 3.1