Release of Invalid Pointer or Reference Affecting liblua5_3-5 package, versions <5.3.6-3.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.75% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBLUA535-2672592
  • published14 Apr 2022
  • disclosed29 Jun 2021

Introduced: 29 Jun 2021

CVE-2020-24371  (opens in a new tab)
CWE-763  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 liblua5_3-5 to version 5.3.6-3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblua5_3-5 package and not the liblua5_3-5 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

lgc.c in Lua 5.4.0 mishandles the interaction between barriers and the sweep phase, leading to a memory access violation involving collectgarbage.

CVSS Base Scores

version 3.1