Integer Overflow or Wraparound Affecting liblz4-1-32bit package, versions <1.9.2-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.4% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBLZ4132BIT-2677634
  • published14 Apr 2022
  • disclosed1 Jun 2021

Introduced: 1 Jun 2021

CVE-2021-3520  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 liblz4-1-32bit to version 1.9.2-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblz4-1-32bit package and not the liblz4-1-32bit package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

CVSS Base Scores

version 3.1