Out-of-bounds Read Affecting libnetcdf_4_7_4-gnu-openmpi4-hpc package, versions <4.7.4-150300.4.7.21


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.15% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBNETCDF474GNUOPENMPI4HPC-7919313
  • published6 Sept 2024
  • disclosed5 Sept 2024

Introduced: 5 Sep 2024

CVE-2017-17507  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libnetcdf_4_7_4-gnu-openmpi4-hpc to version 4.7.4-150300.4.7.21 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnetcdf_4_7_4-gnu-openmpi4-hpc package and not the libnetcdf_4_7_4-gnu-openmpi4-hpc package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

In HDF5 1.10.1, there is an out of bounds read vulnerability in the function H5T_conv_struct_opt in H5Tconv.c in libhdf5.a. For example, h5dump would crash when someone opens a crafted hdf5 file.