CVE-2024-29161 Affecting libpetsc-gnu-mvapich2-hpc package, versions <3.14.5-150300.3.4.4


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.86% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBPETSCGNUMVAPICH2HPC-7920757
  • published6 Sept 2024
  • disclosed5 Sept 2024

Introduced: 5 Sep 2024

CVE-2024-29161  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libpetsc-gnu-mvapich2-hpc to version 3.14.5-150300.3.4.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpetsc-gnu-mvapich2-hpc package and not the libpetsc-gnu-mvapich2-hpc package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

HDF5 through 1.14.3 contains a heap buffer overflow in H5A__attr_release_table, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.

CVSS Base Scores

version 3.1