Out-of-Bounds Affecting libwmf-0_2-7 package, versions <0.2.12-150000.4.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.71% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBWMF027-2808520
  • published5 May 2022
  • disclosed4 May 2022

Introduced: 4 May 2022

CVE-2016-9011  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libwmf-0_2-7 to version 0.2.12-150000.4.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libwmf-0_2-7 package and not the libwmf-0_2-7 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

The wmf_malloc function in api.c in libwmf 0.2.8.4 allows remote attackers to cause a denial of service (application crash) via a crafted wmf file, which triggers a memory allocation failure.