Use After Free Affecting libyui-qt15 package, versions <4.1.5-150300.3.10.5


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-LIBYUIQT15-6613015
  • published14 Apr 2024
  • disclosed11 Apr 2024

Introduced: 11 Apr 2024

CVE-2024-0217  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 libyui-qt15 to version 4.1.5-150300.3.10.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libyui-qt15 package and not the libyui-qt15 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A use-after-free flaw was found in PackageKitd. In some conditions, the order of cleanup mechanics for a transaction could be impacted. As a result, some memory access could occur on memory regions that were previously freed. Once freed, a memory region can be reused for other allocations and any previously stored data in this memory region is considered lost.

CVSS Base Scores

version 3.1