CVE-2025-10529 Affecting MozillaFirefox-translations-common package, versions <140.3.0-150200.152.201.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-MOZILLAFIREFOXTRANSLATIONSCOMMON-13005369
  • published23 Sept 2025
  • disclosed22 Sept 2025

Introduced: 22 Sep 2025

CVE-2025-10529  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 MozillaFirefox-translations-common to version 140.3.0-150200.152.201.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-translations-common package and not the MozillaFirefox-translations-common package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

Same-origin policy bypass in the Layout component. This vulnerability was fixed in Firefox 143, Firefox ESR 140.3, Thunderbird 143, and Thunderbird 140.3.

CVSS Base Scores

version 3.1