XML Injection Affecting netcdf-gnu-hpc package, versions <4.7.4-4.3.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.11% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-NETCDFGNUHPC-2659673
  • published14 Apr 2022
  • disclosed2 Dec 2021

Introduced: 2 Dec 2021

CVE-2021-31347  (opens in a new tab)
CWE-91  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 netcdf-gnu-hpc to version 4.7.4-4.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netcdf-gnu-hpc package and not the netcdf-gnu-hpc package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

An issue was discovered in libezxml.a in ezXML 0.8.6. The function ezxml_parse_str() performs incorrect memory handling while parsing crafted XML files (writing outside a memory region created by mmap).

CVSS Base Scores

version 3.1