CVE-2024-29166 Affecting netcdf-gnu-hpc package, versions <4.7.4-150300.4.7.19


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.21% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-NETCDFGNUHPC-7921022
  • published6 Sept 2024
  • disclosed5 Sept 2024

Introduced: 5 Sep 2024

CVE-2024-29166  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 netcdf-gnu-hpc to version 4.7.4-150300.4.7.19 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netcdf-gnu-hpc package and not the netcdf-gnu-hpc package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

HDF5 through 1.14.3 contains a buffer overflow in H5O__linfo_decode, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.

CVSS Base Scores

version 3.1