Untrusted Search Path Affecting nvidia-container-toolkit package, versions <1.18.0-150200.5.17.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
3.32% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-NVIDIACONTAINERTOOLKIT-14105388
  • published25 Nov 2025
  • disclosed24 Nov 2025

Introduced: 24 Nov 2025

CVE-2025-23266  (opens in a new tab)
CWE-426  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 nvidia-container-toolkit to version 1.18.0-150200.5.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-container-toolkit package and not the nvidia-container-toolkit package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

NVIDIA Container Toolkit for all platforms contains a vulnerability in some hooks used to initialize the container, where an attacker could execute arbitrary code with elevated permissions. A successful exploit of this vulnerability might lead to escalation of privileges, data tampering, information disclosure, and denial of service.

CVSS Base Scores

version 3.1