Memory Leak Affecting opensc package, versions <0.19.0-150100.3.19.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.2% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-OPENSC-3146950
  • published24 Nov 2022
  • disclosed23 Nov 2022

Introduced: 23 Nov 2022

CVE-2019-6502  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 opensc to version 0.19.0-150100.3.19.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensc package and not the opensc package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

sc_context_create in ctx.c in libopensc in OpenSC 0.19.0 has a memory leak, as demonstrated by a call from eidenv.