Incorrect Default Permissions Affecting pdsh-slurm package, versions <2.34-150300.35.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.21% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PDSHSLURM-6358539
  • published3 Mar 2024
  • disclosed8 Dec 2022

Introduced: 8 Dec 2022

CVE-2022-31251  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 pdsh-slurm to version 2.34-150300.35.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pdsh-slurm package and not the pdsh-slurm package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A Incorrect Default Permissions vulnerability in the packaging of the slurm testsuite of openSUSE Factory allows local attackers with control over the slurm user to escalate to root. This issue affects: openSUSE Factory slurm versions prior to 22.05.2-3.3.

CVSS Base Scores

version 3.1