CVE-2024-32619 Affecting pmix package, versions <3.2.3-150300.3.10.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PMIX-7381090
  • published26 Jun 2024
  • disclosed25 Jun 2024

Introduced: 25 Jun 2024

CVE-2024-32619  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 pmix to version 3.2.3-150300.3.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pmix package and not the pmix package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

HDF5 Library through 1.14.3 contains a heap-based buffer overflow in H5T_copy_reopen in H5T.c, resulting in the corruption of the instruction pointer.

CVSS Base Scores

version 3.1