CVE-2022-26520 Affecting postgresql-jdbc package, versions <42.2.25-150300.3.5.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-POSTGRESQLJDBC-6356513
  • published3 Mar 2024
  • disclosed12 Aug 2022

Introduced: 12 Aug 2022

CVE-2022-26520  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 postgresql-jdbc to version 42.2.25-150300.3.5.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-jdbc package and not the postgresql-jdbc package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

In pgjdbc before 42.3.3, an attacker (who controls the jdbc URL or properties) can call java.util.logging.FileHandler to write to arbitrary files through the loggerFile and loggerLevel connection properties. An example situation is that an attacker could create an executable JSP file under a Tomcat web root. NOTE: the vendor's position is that there is no pgjdbc vulnerability; instead, it is a vulnerability for any application to use the pgjdbc driver with untrusted connection properties

CVSS Base Scores

version 3.1