Improper Input Validation Affecting python2-cryptography package, versions <2.9.2-150200.13.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.2% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PYTHON2CRYPTOGRAPHY-3125121
  • published18 Nov 2022
  • disclosed17 Nov 2022

Introduced: 17 Nov 2022

CVE-2018-10903  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 python2-cryptography to version 2.9.2-150200.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2-cryptography package and not the python2-cryptography package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A flaw was found in python-cryptography versions between >=1.9.0 and <2.3. The finalize_with_tag API did not enforce a minimum tag length. If a user did not validate the input length prior to passing it to finalize_with_tag an attacker could craft an invalid payload with a shortened tag (e.g. 1 byte) such that they would have a 1 in 256 chance of passing the MAC check. GCM tag forgeries can cause key leakage.