Improper Verification of Cryptographic Signature Affecting python2-rpm package, versions <4.14.3-37.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.65% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PYTHON2RPM-2668687
  • published14 Apr 2022
  • disclosed12 Aug 2021

Introduced: 12 Aug 2021

CVE-2021-3421  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 python2-rpm to version 4.14.3-37.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2-rpm package and not the python2-rpm package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A flaw was found in the RPM package in the read functionality. This flaw allows an attacker who can convince a victim to install a seemingly verifiable package or compromise an RPM repository, to cause RPM database corruption. The highest threat from this vulnerability is to data integrity. This flaw affects RPM versions before 4.17.0-alpha.

CVSS Base Scores

version 3.1