CVE-2014-8991 Affecting python39-setuptools package, versions <44.1.1-7.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PYTHON39SETUPTOOLS-6356285
  • published3 Mar 2024
  • disclosed23 Jun 2021

Introduced: 23 Jun 2021

CVE-2014-8991  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 python39-setuptools to version 44.1.1-7.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python39-setuptools package and not the python39-setuptools package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

pip 1.3 through 1.5.6 allows local users to cause a denial of service (prevention of package installation) by creating a /tmp/pip-build-* file for another user.

CVSS Base Scores

version 3.1