Resource Exhaustion Affecting python3-constantly package, versions <15.1.0-150000.3.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.83% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PYTHON3CONSTANTLY-5756607
  • published6 Jul 2023
  • disclosed4 Jul 2023

Introduced: 4 Jul 2023

CVE-2018-1000518  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 python3-constantly to version 15.1.0-150000.3.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-constantly package and not the python3-constantly package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that can result in Denial of Service by memory exhaustion. This attack appear to be exploitable via Sending a specially crafted frame on an established connection. This vulnerability appears to have been fixed in 5.

CVSS Base Scores

version 3.1