Use of a Broken or Risky Cryptographic Algorithm Affecting python3-rsa package, versions <3.4.2-3.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.43% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-PYTHON3RSA-2674670
  • published14 Apr 2022
  • disclosed17 Jun 2021

Introduced: 17 Jun 2021

CVE-2020-13757  (opens in a new tab)
CWE-327  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 python3-rsa to version 3.4.2-3.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-rsa package and not the python3-rsa package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

Python-RSA before 4.1 ignores leading '\0' bytes during decryption of ciphertext. This could conceivably have a security-relevant impact, e.g., by helping an attacker to infer that an application uses Python-RSA, or if the length of accepted ciphertext affects application behavior (such as by causing excessive memory allocation).

CVSS Base Scores

version 3.1