Information Exposure Affecting ruby2.5-rubygem-actionpack-5_1 package, versions <5.1.4-3.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.08% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-RUBY25RUBYGEMACTIONPACK51-2678781
  • published14 Apr 2022
  • disclosed26 May 2021

Introduced: 26 May 2021

CVE-2021-22885  (opens in a new tab)
CWE-209  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 ruby2.5-rubygem-actionpack-5_1 to version 5.1.4-3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-actionpack-5_1 package and not the ruby2.5-rubygem-actionpack-5_1 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the redirect_to or polymorphic_urlhelper with untrusted user input.

CVSS Base Scores

version 3.1