Inefficient Regular Expression Complexity Affecting ruby2.5-rubygem-actionpack-5_1 package, versions <5.1.4-150000.3.15.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.28% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-RUBY25RUBYGEMACTIONPACK51-3325259
  • published18 Feb 2023
  • disclosed17 Feb 2023

Introduced: 17 Feb 2023

CVE-2023-22795  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 ruby2.5-rubygem-actionpack-5_1 to version 5.1.4-150000.3.15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-actionpack-5_1 package and not the ruby2.5-rubygem-actionpack-5_1 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A regular expression based DoS vulnerability in Action Dispatch <6.1.7.1 and <7.0.4.1 related to the If-None-Match header. A specially crafted HTTP If-None-Match header can cause the regular expression engine to enter a state of catastrophic backtracking, when on a version of Ruby below 3.2.0. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability All users running an affected release should either upgrade or use one of the workarounds immediately.

CVSS Base Scores

version 3.1