CVE-2022-44566 Affecting ruby2.5-rubygem-activerecord-5_1 package, versions <5.1.4-150000.5.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.27% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-RUBY25RUBYGEMACTIVERECORD51-3330788
  • published24 Feb 2023
  • disclosed23 Feb 2023

Introduced: 23 Feb 2023

CVE-2022-44566  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 ruby2.5-rubygem-activerecord-5_1 to version 5.1.4-150000.5.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-activerecord-5_1 package and not the ruby2.5-rubygem-activerecord-5_1 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. When a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.

CVSS Base Scores

version 3.1