Race Condition Affecting rustup package, versions <1.25.1~0-150300.7.13.2


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.24% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-RUSTUP-3123815
  • published17 Nov 2022
  • disclosed11 Nov 2022

Introduced: 11 Nov 2022

CVE-2021-45710  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 rustup to version 1.25.1~0-150300.7.13.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rustup package and not the rustup package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

An issue was discovered in the tokio crate before 1.8.4, and 1.9.x through 1.13.x before 1.13.1, for Rust. In certain circumstances involving a closed oneshot channel, there is a data race and memory corruption.

CVSS Base Scores

version 3.1