Incorrect Authorization Affecting slurm_22_05-torque package, versions <22.05.11-150300.7.12.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-SLURM2205TORQUE-10266192
  • published30 May 2025
  • disclosed29 May 2025

Introduced: 29 May 2025

CVE-2025-43904  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 slurm_22_05-torque to version 22.05.11-150300.7.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm_22_05-torque package and not the slurm_22_05-torque package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

In SchedMD Slurm before 24.11.5, 24.05.8, and 23.11.11, the accounting system can allow a Coordinator to promote a user to Administrator.

CVSS Base Scores

version 3.1