Out-of-bounds Write Affecting snakeyaml package, versions <1.31-150200.3.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.91% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-SNAKEYAML-3036051
  • published29 Sept 2022
  • disclosed26 Sept 2022

Introduced: 26 Sep 2022

CVE-2022-38751  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 snakeyaml to version 1.31-150200.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream snakeyaml package and not the snakeyaml package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.

CVSS Base Scores

version 3.1