Integer Underflow Affecting strongswan-libs0 package, versions <5.8.2-150200.11.45.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.98% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-STRONGSWANLIBS0-13776113
  • published30 Oct 2025
  • disclosed29 Oct 2025

Introduced: 29 Oct 2025

CVE-2025-62291  (opens in a new tab)
CWE-191  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 strongswan-libs0 to version 5.8.2-150200.11.45.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan-libs0 package and not the strongswan-libs0 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

In the eap-mschapv2 plugin (client-side) in strongSwan before 6.0.3, a malicious EAP-MSCHAPv2 server can send a crafted message of size 6 through 8, and cause an integer underflow that potentially results in a heap-based buffer overflow.

CVSS Base Scores

version 3.1